Vamos a combinar BuscarV y Coincidir para extraer datos en una columna que puede ser variable

Ya en anteriores entradas hemos hablado de la utilidad de la función BuscarV. Te recuerdo que permite buscar valores en la primera columna de una tabla de datos y extraer el dato de dicha fila, situado en el número de columna que digamos. La sintaxis es la siguiente:

BuscarV(valorBuscado;tabla;columna;tipo)

Si no lo recuerdas, te remito a la entrada correspondiente, haz clic aquí.

Nos vamos a centrar ahora en el tercer argumento. Es el que indicaría el número de columna en que está situado el dato que queremos extraer, dentro de la tabla. Normalmente escribiremos eso, un número, pero un número fijo, 3, 4 o 5, etc.

Supongamos la siguiente tabla de datos:

Tabla de datos de películas
Tabla de datos de películas

Y ahora queremos poner al lado un pequeño cuadro en el cual elegimos la película de una lista desplegable, elegimos el dato que queremos consultar en otra lista y obtenemos el dato en cuestión.

Por ejemplo, queremos saber cual es el año en que se hizo la película “Los siete samuráis”.

En la primera lista elegimos Los siete samuráis.

En la segunda, año (que es el dato a consultar)

Y nos debe aparecer 1954. Así:

Selección del año como dato a extraer
Selección del año como dato a extraer

Si ahora queremos ver el estado en que se encuentra, seleccionamos Estado de la segunda lista. Así:

Selección en la cual queremos ver el estado de la película
Selección en la cual queremos ver el estado de la película

Comienza realizando las dos listas.

Si quieres repasar cómo se hacían las listas desplegables, haz clic aquí para ver la entrada correspondiente.

En la primera, el rango origen de la lista, tiene que incluir todos los títulos de las películas. En este caso del ejemplo sería el rango A2:A26.

En el segundo rango hay que poner como origen, el lugar en que se encuentran los encabezados. En el ejemplo sería A1:D1.

Para que todo esto funcione, deberíamos usar la fórmula BuscarV extrayendo en el primer ejemplo la columna 2, y la columna 3 para el segundo. Más o menos sería así:

=BUSCARV(F3;A2:D26;2;VERDADERO)

para el ejemplo 1. Y

=BUSCARV(F3;A2:D26;3;VERDADERO)

para el ejemplo 2.

Pero claro, no vamos a estar cambiando la fórmula cada vez que queremos una columna diferente.

Usaremos la función Coincidir. La función coincidir devuelve un número que es la posición dentro de una matriz del valor buscado. Justo lo que necesitamos. Si sabemos la posición de “Año”, “Estado” y PVP dentro de los encabezados, tenemos la solución.

La sintaxis de Coincidir es como sigue:

Coincidir(valorBuscado;matriz;tipocoincidencia)

ValorBuscado es lo que queremos encontrar. Para nuestro caso es lo que está situado en F5 y es el valor de la segunda lista.

Matriz es dónde queremos saber si se encuentra el valor a buscar. En nuestro caso son los encabezados que se encuentran en A1:D1.

tipocoincidencia es un número que indica cómo tiene que ser dicha coincidencia. En nuestro caso elegimos 0 pues tiene que ser coincidencia exacta.

La fórmula final quedaría así:

=BUSCARV(F3;A2:D26;COINCIDIR(F5;A1:D1;0);VERDADERO)

Recuerda que al poner una función dentro de otra (anidada, se llama) se van calculando siempre de dentro hacia afuera. Esto quiere decir que primero se evaluará el coincidir y el valor resultado será el tercer parámetro de la función BuscarV

¿Qué tal? ¿Te funcionó? Puedes extenderlo para hacer búsquedas en tablas que tengan muchísimos datos y obtener una respuesta de forma rápida.

 

Anuncios

One thought on “Vamos a combinar BuscarV y Coincidir para extraer datos en una columna que puede ser variable

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s